Abstract

This technical report (TR) introduces the reporting features that are available with NetApp® OnCommand® Unified Manager for the NetApp clustered Data ONTAP® operating system. Reporting features were introduced in OnCommand Unified Manager 6.2. This TR describes in detail how to implement the reporting functionality within OnCommand 6.2 and 6.3. It also describes how to manage and implement custom reports, including how to export and import external reports. This TR also gives examples of reports and reference information for creating native and custom reports within the OnCommand realm.
# TABLE OF CONTENTS

1. Purpose ........................................................................................................................................ 3
2. Scope ............................................................................................................................................. 3
3. Glossary of Terms .......................................................................................................................... 3
4. Introduction .................................................................................................................................... 3
   4.1 OnCommand Report Features ................................................................................................. 4
5. Architecture Overview ..................................................................................................................... 4
6. Reporting Objects ........................................................................................................................... 5
   6.1 Annotation ................................................................................................................................. 5
   Rules and Values in Annotation ........................................................................................................ 5
   6.2 Create Annotations .................................................................................................................... 6
   In OCUM 6.2 .................................................................................................................................. 6
   In OCUM 6.3 .................................................................................................................................. 8
7. Reporting Dashboard ....................................................................................................................... 11
   7.1 Reporting Functions ................................................................................................................. 12
   View Reports ............................................................................................................................... 12
   Run a Report ............................................................................................................................... 13
   Schedule a Report ....................................................................................................................... 13
   Enhance Canned (Built-in) Reports ............................................................................................... 14
8. Custom Reports ............................................................................................................................... 15
   8.1 Create Reports with Eclipse ..................................................................................................... 16
   Prerequisites ............................................................................................................................... 16
   Create a Custom Report Project ................................................................................................... 17
   8.2 Create a Custom Report ........................................................................................................... 20
9. Portability of (Custom) Reports ......................................................................................................... 26
   9.1 Connection Profile ................................................................................................................... 26
   Advantages of Using a Connection Profile ................................................................................... 27
   Prerequisites ............................................................................................................................... 27
   9.2 Create a Connection Profile .................................................................................................... 28
   9.3 Create Reports by Using a Connection Profile ......................................................................... 30
   Import Reports by Using a Connection Profile ............................................................................. 38
   Configuration Changes ................................................................................................................ 38
References ........................................................................................................................................... 39

OnCommand Unified Manager Reporting for Clustered Data ONTAP
1 Purpose

This document provides information to help OnCommand Unified Manager administrators and storage administrators effectively use the reporting and custom reporting functionalities in OnCommand Unified Manager 6.2 and 6.3. We provide workable examples along with this documentation.

2 Scope

This document intends to assist storage administrators, IT managers, and capacity managers in preparing customized, comprehensive reports for the entire NetApp infrastructure in their organization.

3 Glossary of Terms

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OCUM</td>
<td>OnCommand Unified Manager</td>
</tr>
<tr>
<td>UM</td>
<td>Unified Manager</td>
</tr>
<tr>
<td>BIRT</td>
<td>Business intelligence reporting tool from OpenText; the embedded reporting engine in OCUM 6.2</td>
</tr>
<tr>
<td>Eclipse</td>
<td>Open-source integrated development environment used to create report definitions for BIRT</td>
</tr>
<tr>
<td>SVM</td>
<td>Storage virtual machine</td>
</tr>
<tr>
<td>Vserver</td>
<td>Virtual storage server, same as SVM</td>
</tr>
</tbody>
</table>

4 Introduction

An IT environment requires accurate and comprehensive reporting of its assets. These reports could be informational, for measuring storage and capacity information, or just for administrative documentation. As the number of reports increases, so does the complexity of the reporting process.

Starting with OnCommand Unified Manager 6.2, NetApp has introduced a reporting feature that provides a comprehensive library of standard reports about the underlying NetApp storage infrastructure. Administrators can easily obtain the information that they need. In addition, OnCommand Unified Manager 6.2 extends the reporting capabilities to capture only desired data objects through its customized, rich reporting feature.
With OCUM 6.3, the reporting capabilities have been further enhanced:

- OnCommand Unified Manager 6.3 allows annotation tables to be exposed as a database view, facilitating custom report creation by annotation dimensions.

- In OnCommand Unified Manager 6.3, custom reports without table elements in the report design can be imported. Section 9, Portability of (Custom) Reports, provides more details.

4.1 OnCommand Report Features

An OnCommand report provides storage visibility and analytics for NetApp hosted storage systems in the enterprise. Operating as agentless, browser-based software, OnCommand reports enable you to create extensive reports on:

- Operations management: events, severity, and status trend charts
- Capacity: storage summary, aggregate, volume, qtree
- Inventory: cluster, SVM, volumes

You can leverage the reporting feature in OCUM 6.2 to:

- Customize core reports for additional use cases:
  - Group, filter, sort, add compute fields, hide, and delete at the column level (for each column) in the report.
  - Get hints to customize the preceding list of additional use cases.
- Export and import report definitions to allow sharing.
- Schedule and share reports; view reports in PDF, CSV, XLS, HTML, or TXT format.
- Group storage resources with a single identifier for analysis and reporting; for example, by business function or by application.
- Make full use of Eclipse, a third-party tool, to create custom, comprehensive reports that you can import to UM as a design template.

5 Architecture Overview

Unified Manager has its own reporting content in conjunction with a wrapper to support the third-party OpenText BIRT component. It also includes an Eclipse-based tool that connects to OCUM over port 3306 by using a MySQL Java Database Connectivity (JDBC) driver. Users can interact to view reports online (in real time) and offline through sharing or exporting, or through scheduling of canned and imported reports.

A database called ocum_report has been added to the OCUM server, and it is accessible through an OCUM database user who has a report schema role. This database provides wrapper views on
OnCommand Unified Manager to support imported reports that are created by using Eclipse. BIRT uses various customized, feature-rich RESTful APIs for background tasks: Share, Schedule, and Import Reports created from BIRT.

6 Reporting Objects

6.1 Annotation

An annotation is a combination of a name-value pair that can be applied over storage objects in clustered Data ONTAP—clusters, SVMs, and volumes—dynamically by using user-defined rules. This capability helps create storage tags that can be used for reporting and administration of storage objects that are linked to the tag. An annotation can bring together SVMs, volumes, and clusters in a single group for better manageability.

An annotation name refers to the metadata that is associated with storage objects; examples of an annotation include an application, a data center, and a business unit. A storage object can be associated with one or more unique annotation names; for example, a volume can be associated with an application, a data center, or a business unit.

An annotation value is the value associated with an annotation name. For example, Data Center = New York, Application = Exchange, Business Unit = Finance. For a given object, an annotation name can be associated with only one value.

With OCUM 6.2, you can create custom annotations by applying rules to augment supported storage objects—clusters, SVMs, and volumes. The following conditions hold true for annotation association:

- A given storage object can have any number of annotation labels associated with it.
- A storage object can have only one annotation value for a given annotation name.

Rules and Values in Annotation

The rule editor contains a list of rules for applying annotations to storage objects. A rule is a statement that involves:

- A storage object
- A condition
- An action

The storage object could be a FlexVol™, an SVM, or a cluster.

Each rule is in the following format:

```
if ($CLUSTER.NAME == 'clusterName') then { $CLUSTER.Location = <value_name> }
```

In this format, Location is the annotation name and <value_name> is the annotation value in this example.
Table 1) The following table defines the parameters or building blocks that could be used in creating rule logic:

<table>
<thead>
<tr>
<th>Building Block</th>
<th>Description</th>
<th>Building Block</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>$VOLUME.NAME</td>
<td>Used for the volume name.</td>
<td>VOLUME.SVM.NAME</td>
<td>Used for the SVM name containing all the volumes.</td>
</tr>
<tr>
<td>$SVM.NAME</td>
<td>Used for the SVM name.</td>
<td>$VOLUME.CLUSTER.NAME</td>
<td>Used for the cluster name containing all the volumes.</td>
</tr>
<tr>
<td>$CLUSTER.NAME</td>
<td>Used for the cluster name.</td>
<td>$SVM.CLUSTER.NAME</td>
<td>Used for the cluster name containing all the SVMs.</td>
</tr>
</tbody>
</table>

Starting OCUM 6.3, the creation of rules is very intuitive. Once you have created an annotation, add values to the annotation, and then navigate to the “manage rule” tab to create definitions for associating storage units to the annotation values.

6.2 Create Annotations
To create an annotation, use the following procedure:

**In OCUM 6.2**

1. Log in to Unified Manager as the OnCommand administrator.
2. Navigate to Administration → Manage Annotations.
3. Create an annotation and add the annotation name and description.

4. After the annotation name has been created, you can add the possible values for it. First select the created annotation and then select the New Value option. The required input is the value name.

5. To add rules to the value, click the Manage Rules button on the right-hand side.
Following is an example of a rule syntax:

```plaintext
if ($VOLUME.SVM.NAME == 'wdginclus-35') then {$VOLUME.Imp-SVMs = wdginclus-35}
```

Where:
- `wdginclus-35` is the value.
- `Imp-SVMs` is the annotation name.
- `$VOLUME.SVM.NAME` is the rule parameter used.

When the rule has been created, it must be validated and then saved. **Only validated rules can be saved.**

**Note:**
- Rules are maintained and managed as a global list. There is no annotation name- or value-specific view of rules in OnCommand Unified Manager 6.2.
- Annotation names and values must be created before being used in a rule.
- The correctness of the rules can be verified by clicking the Validate button.

**In OCUM 6.3**
1. Log in to Unified Manager as the OnCommand administrator.
2. Navigate to Administration → Manage Annotations.
3. Create an annotation and add the annotation name and description

4. Add value to the annotation
5. Once added, click on manage rules tab to define the storage unit association to the value “Boston” in the annotation:

6. Furnish the details on the rules creation page
Step 1: Click on “Add”  
Step 2: Give a name for your rule  
Step 3: Select the target object type you desire. You can select – SVM, Volume or Cluster  
Step 4: Apply this rule to the annotation you desire  
Step 5: Associate this rule to the value you desire  
Step 6: Add conditions to your rule, selections can be Cluster, SVM or volume name  
Step 7: Apply the condition logic – either “contains” or “is” for specific match  
Step 8: Enter the exact name or part of the name string you want to match in your search  

Once complete, click on “Save and Add” and close the window.

7 Reporting Dashboard  
The reporting dashboard is the main page where all the reports are categorized and listed. The various reports available fall into one of the following categories:  
- Capacity utilization  
- Operational  
- Inventory  
- Imported  

To navigate to a reporting dashboard, click the Reports tab.  

In the dashboard, the first three categories contain built-in reports. To view the reports in a category, expand that category. You can further customize these reports by excluding certain fields; this step is explained in section 6.1.  

In last reporting category, Imported Reports, you can use Eclipse, an open-source reporting designer (free license), or the OpenText Actuate Analytics Designer (free commercial-grade designer) to customize reporting to meet your comprehensive needs. To customize Imported Reports, the BIRT reporting engine must be installed on the system.  

For further details on BIRT, go to the following the links. These links also provide information about installation procedures for the respective packages:  
- Eclipse IDE for Java and Report Developers:  
7.1 Reporting Functions

The reporting function in OnCommand helps you get a comprehensive view of the NetApp devices in the environment: capacity management, operations management, and so on. In particular, you can perform the following categories of OnCommand reporting functions:

- View reports under the reporting categories listed in the dashboard, as mentioned previously.
- Run a report.
- Schedule a report.
- Further customize canned reports.
- Import a report from the third-party Eclipse designer tool.

View Reports

You can expand each of the reporting categories to view the various reporting capabilities within the category. For example, when you expand the Capacity Utilization category, the following built-in reports are available:

```
- Capacity Utilization
  - Storage Summary
  - Aggregate Capacity and Utilization
  - Volume Capacity and Utilization
  - Qtree Capacity and Utilization
```
Run a Report

To run a report, expand a category and click the Run Report button next to the report that you want. You are then taken to the report details page.

Schedule a Report

With the scheduling feature, you can schedule a specific report and send the report to administrators and other requisite recipients by e-mail. Various reporting formats are supported, including PDF, HTML, CSV, Excel, and so on.

To schedule a report, go to the individual report summary page. Click Manage Report Schedules and then complete the following fields:

- Schedule Name
- Recipient E-mail Address
- Report Format
- Frequency (of the reporting intervals)
- Report Category

The drag-and-drop feature allows you to add specific fields within the schedule.
Enhance Canned (Built-in) Reports

You can further customize the canned, built-in reports by selecting only the reporting fields that you want to view in your report. To customize a report, you must first enable interactivity on the report by selecting Enable Interactivity.

When interactivity has been enabled, you can customize your report to sort, filter, or delete a row or a column from the report. When the report has completed, you can either save the modified report for future reference or schedule the same report run.
To customize a built-in report, click any of the columns in the report and explore the various features that are available at your disposal.

8 Custom Reports

You can import customized reports built from the Eclipse tool into the OnCommand Unified Manager server by using the import feature in OCUM. Report designs that you create by using Eclipse are saved as XML files with an .rptdesign extension.

To import a report:

1. On the report landing page, click Import Report at the top of the page. An import report window then opens.
2. In the Import Report window:
   a. Browse to the .rptdesign file that you intend to import and click Open.
   b. Provide a name for the report.
   c. Add a description for the report.
   d. Click Import.

The imported report is now available on the report landing page, under the Imported Reports category.

Note: In an OCUM 6.2 instance, if a report (.rptdesign file) does not have table elements in the report design, it cannot be imported. NetApp has rectified this limitation in OnCommand Unified Manager 6.3. For further information, follow BURT 879029.

8.1 Create Reports with Eclipse

To produce feature-rich custom reports, you can leverage the open-source Eclipse tool or the OpenText Actuate Analytics Designer.

To install the Eclipse tool, use either of the following links:

- “All-in-one” package: http://download.eclipse.org/birt/downloads/

To download the OpenText Actuate Analytics Designer, go to:

- http://birt.actuate.com/products/analytics-designers/analytics-designer

You can install Eclipse on the Windows, Mac OS X, or Linux operating system. To set up and configure the designer of your choice, follow the installation instructions that are available with the software.

Prerequisites

Eclipse needs a connection to the OnCommand Unified Manager database. Eclipse uses port 3306 to connect to the OCUM server through a JDBC connector and a database user for authorization.

To create a database user in the OCUM server, you must:

1. Log in to OCUM as the OnCommand administrator.
2. Navigate to Administration → Manage Users.
3. Click Add, and add a database user with Report Schema as the Role definition.

Create a Custom Report Project

In this section, we assume that you have set up Eclipse on another system by following the instructions in the steps and procedures in section 8.1.

These instructions are based on the Windows version of Eclipse. The Linux and Mac OS X versions behave similarly.

To create a custom report:

1. Log in to the system that is hosting Eclipse and open the application.

3. To create a new project, navigate to File → New → Project. The following screen appears.
4. In the wizard, click New Report Project and click Next.

5. On the Eclipse launching page, create a new project. Navigate to New Project → Report Project and then click Next. Provide a name for the project and click Finish.
8.2 Create a Custom Report

1. To create a new report under a project, click File → New → Report.

Alternatively, you can right-click the new project and select New. In the selections, click Report.
2. Provide a name for the new report. You can use the default location, or to type in a new location where you want to store all reports, uncheck the Use Default Location box. Click Next.

3. Create a new data source. Click the project and then right-click Data Source. Select New Data Source.
4. Select the Create from a Data Source Type in the Following List and then select JDBC Data Source from the drop-down menu. Type a name in the Data Source Name field. Click Next.

Note: If you have already created a connection profile, you can instead select Create from a Connection Profile in the Profile Store. For details about the benefits and use of a connection profile see section 9.1, Connection Profile.
5. Provide the database URL (replace the IP here with the FQDN/IP of Unified Manager), user
name, and password from the Prerequisites section. In addition, provide the following information
in the applicable fields:
   a. Add the database driver by clicking the Manage Drivers button. Select the mysql-
      connector-java-*-bin.jar file that is available to you.
   b. Driver Class: com.mysql.jdbc.Driver (v5.1). This name is available as a drop-
      down selection.
   c. Database URL: jdbc:mysql://<ip address of OCUM
      server>:3306/ocum_report.
   d. User Name: The name of the database user that was created in the OCUM server for the
      BIRT designer.
   e. Password: The password of the database user.

Note:
- You need not fill in the “JNDI URL” field. This is not required
- You should test the connection by clicking Test Connection to validate a successful connection to
  the OnCommand Unified Manager database. Then click Finish.
- You can use the FQDN instead of the IP address for the Database URL.
- For an IPv6 address, the Database URL field should be in the following format:
  

  Where host=fd20:8b1e:b255:8477:42f:11e:64e3:5338 is the host IPv6 address.
6. Create a dataset. Navigate to Data Explorer → Data Set and click New Data Set.

7. Select the data source that you created in step 4 and:
   a. Select SQL Select Query from the Data Set Type drop-down menu.
   b. Type in a name under Data Set Name.
   c. Click Next.
8. When the SQL query window appears, define a SQL query for the report that you want to produce. To create a query, use the fields from the Available Items on the left-hand side. Expand an item to use the fields that are available under that item.

When you have completed your selections, click Finish to view the results.

**Note:** If an incorrect query syntax or logic statement has been submitted, an error occurs and the user is alerted with a popup message.

9. Select the output columns that must be part of the report and click OK.
10. Drag the columns from the Data Sets to the Detail Row in the table in the order that you want to present them.

11. After you have saved the query, you can review the output by using a browser. Select the report available in the bottom left-hand corner and click Run → View Report → As HTML.

![Image of report design interface]

12. To import this report into OnCommand Unified Manager, locate the new_report.rptdesign file, which is normally available under the workspace location that you defined during installation of Eclipse. Copy this file to a system that can browse Unified Manager and use the importing function as explained in section 8. Importing Reports.

9 Portability of (Custom) Reports

Custom OCUM reports created through the BIRT designer can be imported from one environment to another. That is, you can now import a report (.rptdesign) file that you created in OCUM instance A to OCUM instance B seamlessly, but with a few configuration changes, which are detailed in the following sections.

9.1 Connection Profile

A connection profile contains the connection property information that is required to connect to a data source (in this case, an OnCommand Unified Manager database). By using a connection profile, administrators don’t have to repeat the connection definitions or add the required MySQL drivers multiple times for each “custom” report to be created under a single Unified Manager instance. In addition, an administrator can also use connection profiles to port external BIRT reports (.rptdesign files) from another environment.
A connection profile is an XML file with an `.acconnprofiles` extension that contains the database connection–related data that the BIRT run-time environment understands. Optionally, you can encrypt the entire content in the connection profile. The following are the major components in a connection profile:

- Data source name
- Database server class information
- Database URL that connects to the OCUM database
- Database user name and password to connect to the OCUM database

**Advantages of Using a Connection Profile**

With a connection profile, you can:

- Create the profile just once for multiple or all the reports that are used in a Unified Manager instance and its associated storage objects.
- Create multiple reports without having to reenter the connection parameters (database driver, user name, and password), thereby saving a lot of time.
- With a simple understanding of the connection profile, import the same report to multiple OCUM instances (the same file name but different parameters).
- Encrypt content (optional).

**Prerequisites**

The following components are required to create a connection profile. You can download these components in the host where you are installing the BIRT instance:

- BIRT designer editor (Eclipse with a BIRT plug-in or Eclipse from Actuate).
- Fully operational OCUM server with a report user created.

**Note:** The OCUM server must be in the same network as that of the server that hosts the BIRT designer, or, at a minimum, it should have port 3306 allowed.
9.2 Create a Connection Profile

Before you can create a connection profile, you must create a report user on the OnCommand Unified Manager server. Log in to the OCUM server in your environment and navigate to Administration ➔ Manage Users. Create a report user with the user type Database User and with the role Report Schema.

![Add User dialog](image)

Database users with the Report Schema role, have read-only permissions to access report-specific database views directly from the database.

- **Type:** Database User
- **Name:** ocum_report_user
- **Password:** ********
- **Confirm Password:** ********
- **Role:** Report Schema

Now log in to the host where you are installing the BIRT station. The following steps guide you in the creation of a connection profile:

1. From the main menu, select File ➔ New ➔ Other.
2. Under Connection Profiles, select Connection Profile from the wizard and click Next.

![Select a wizard dialog](image)

OnCommand Unified Manager Reporting for Clustered Data ONTAP
3. Select the connection profile type.
4. Enter a unique name for the connection profile type.
5. Select BIRT JDBC Data Source under Connection Profile Types. Enter a name and a description identifier for the datastore. Click Next.

![New Connection Profile Wizard](image)

**Note:** Make sure that you write down the data source name. This information is extremely important from a report portability perspective. If you need to import another report (an .rptdesign file from an external BIRT server or from another environment), your BIRT server must have the same data source name while creating the connection profile.

6. Complete the required information in the wizard for your connection profile type. Provide the database URL (replace the IP here with the FQDN/IP of Unified Manager), the user name, and the password from the Prerequisites section. In addition, complete the following fields with your information:
   a. Add the database driver by clicking the Manage Drivers button. Select the mysql-connector-java-*-.jar file that is available to you.
   b. Driver Class: com.mysql.jdbc.Driver (v5.1). This name is available as a drop-down selection.
   d. User Name: The name of the database user that was created in the OCUM server for the BIRT designer.
   e. Password: The password of the database user

**Note:** For an IPv6 address, the Database URL field should be in the following format:

Where host=fd20:8b1e:b255:8477:42f:11e:64e3:5338 is the host IPv6 address.

7. Test for a successful connection to the OCUM database through the Test Connection button in the New JDBC Data Source Profile window.

9.3 Create Reports by Using a Connection Profile

To create a report by using a connection profile:

Alternatively, you can right-click the new project and select New. In the selections, click Report.
2. Provide a name for the new report. You can use the default location to store all reports by checking the Use Default Location box. Click Next.
3. Select the type of report from the report template; in this case, we have selected a blank report. Click Finish.

![New Report Dialog Box](image1)

4. For the new report, create a data source by using the connection profile option. Click Next.

![Select a Data Source Type or Choose a Connection Profile](image2)
5. On the Connection Profile screen, click New.

6. Select your connection profile. Provide a file name and a path in the Specify a File Name field to create a profile at that location.

   **Note:** This step is one-time operation; after you have taken this step, you can always choose this file in step 5 by clicking Browse.
7. In Create a Connection Profile Store, click OK.

8. Click Next and then Finish.
9. After the process has finished, you can see the connection profile with the .acconprofiles in your workplace, and a datastore is created for you.

10. Now you can create a dataset with the desired query to create a report. Click Next to query for the dataset.
11. Fill in the query and click Finish.

Note:
- You should create the data source by using a connection profile.
- Do not provide a name for the data source.
- You should select the Use the Default Data Source Name checkbox.
- Create an encrypted connection profile. (This step is optional and is offered in case you want a secure method of communication.)
- The .rptdesign file with a connection profile has the following lines under the Data Sources design element. You can review the lines in bold to identify that the report is using a connection profile.
<property name="odaDriverClass">com.mysql.jdbc.Driver</property>
<property name="odaURL">jdbc:mysql://192.168.1.1:3306/ocum_report</property>
<property name="odaUser">birtuser</property>
<encrypted-property name="odaPassword" encryptionID="base64">bmV0YXBwMSE=</encrypted-property>
<property name="OdaConnProfileName">NtapReport</property>
<property name="OdaConnProfileStorePath">Conn/ntap_conn.acconprofiles</property>

Note: For an IPv6 address, the database URL should be in the following format:
Where host=fd20:8b1e:b255:8477:42f:11e:64e3:5338 is the host IPv6 address.

Import Reports by Using a Connection Profile

To import external .rptdesign files into your environment:

- You must have a connection profile that was created in your OnCommand Unified Manager instance before you can start importing a report by using the connection profile.
- You should use one connection profile per OCUM instance. The same connection profile cannot be used for multiple OCUM instances.
- Reports that are imported with or without connection profiles stop working if:
  - The report user is deleted.
  - The report user password is changed in the OCUM server.
  - The OCUM server URL has changed (it must be the same URL that you used when you created a data source profile; for example, jdbc:mysql://192.168.1.1:3306/ocum_report).
- You should keep a copy of the original .rptdesign file that you want to import.

Note:
- You can replace the IP address with the OCUM server FQDN in the Database URL field.
- For an IPv6 address, the Database URL field should be in the following format:
  Where host=fd20:8b1e:b255:8477:42f:11e:64e3:5338 is the host IPv6 address.

Configuration Changes

To import an external .rptdesign file, you need to make a few configuration adjustments:

1. Log in to the OCUM instance and create a directory called Conn under the reports directory. For Linux systems, the default location is /opt/netapp/ocum/reports/.
   
   Note: For OnCommand Unified Manager servers that are deployed as vApp, you log in to the server by using root credentials.

2. Copy the connection profile that you created for this OCUM instance to the Conn directory.
3. Change the .rptdesign file contents to point to this connection profile location. (The following example is from an OCUM instance that is installed in Linux; you should find equivalent information for Windows.)

From

```xml
<property name="OdaConnProfileStorePath">Conn/ntap_conn.acconprofiles</property>
```

To

```xml
<property name="OdaConnProfileStorePath">/opt/netapp/ocum/reports/Conn/ntap_conn.acconprofiles</property>
```

4. To help confirm that the report gets connected by using the connection profile, you can remove the following lines. These lines are optional, and BIRT uses them for a fallback mechanism if it is unable to connect through the connection profile:

```xml
<property name="odaDriverClass">com.mysql.jdbc.Driver</property>
<property name="odaURL">jdbc:mysql://192.168.1.1:3306/ocum_report</property>
<property name="odaUser">birtuser</property>
<encrypted-property name="odaPassword" encryptionID="base64">bmV0YXBwMSE=</encrypted-property>
```

**Note:** For an IPv6 address, the database URL should be in the following format:

```
```

Where `host=fd20:8b1e:b255:8477:42f:11e:64e3:5338` is the host IPv6 address.

5. Now import the external .rptdesign file.

**References**

- NetApp OnCommand customer community in which users post questions and subject-matter experts respond, and users can interact with peers
  

- OnCommand Unified Manager on NetApp.com
  

- OnCommand Unified Manager on the NetApp TechComm TV channel on YouTube
  
  [https://www.youtube.com/watch?v=34Pzo0KuMOQ](https://www.youtube.com/watch?v=34Pzo0KuMOQ)

- Download site for the latest version of Unified Manager and product documentation
  
  [mysupport.netapp.com](http://mysupport.netapp.com)
Refer to the Interoperability Matrix Tool (IMT) on the NetApp Support site to validate that the exact product and feature versions described in this document are supported for your specific environment. The NetApp IMT defines the product components and versions that can be used to construct configurations that are supported by NetApp. Specific results depend on each customer's installation in accordance with published specifications.

Copyright Information

Copyright © 1994–2015 NetApp, Inc. All rights reserved. Printed in the U.S. No part of this document covered by copyright may be reproduced in any form or by any means—graphic, electronic, or mechanical, including photocopying, recording, taping, or storage in an electronic retrieval system—without prior written permission of the copyright owner.

Software derived from copyrighted NetApp material is subject to the following license and disclaimer:

THIS SOFTWARE IS PROVIDED BY NETAPP "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, WHICH ARE HEREBY DISCLAIMED. IN NO EVENT SHALL NETAPP BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

NetApp reserves the right to change any products described herein at any time, and without notice. NetApp assumes no responsibility or liability arising from the use of products described herein, except as expressly agreed to in writing by NetApp. The use or purchase of this product does not convey a license under any patent rights, trademark rights, or any other intellectual property rights of NetApp.

The product described in this manual may be protected by one or more U.S. patents, foreign patents, or pending applications.

RESTRICTED RIGHTS LEGEND: Use, duplication, or disclosure by the government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.277-7103 (October 1988) and FAR 52-227-19 (June 1987).

Trademark Information

NetApp, the NetApp logo, Go Further, Faster, AltaVault, ASUP, AutoSupport, Campaign Express, Cloud ONTAP, Clustered Data ONTAP, Customer Fitness, Data ONTAP, Data Motion, Fitness, Flash Accel, Flash Cache, Flash Pool, FlashRay, FlexArray, FlexCache, FlexClone, FlexPod, FlexScale, FlexShare, FlexVol, FPolicy, GetSuccessful, LockVault, Manage ONTAP, Mars, MetroCluster, MultiStore, NetApp Insight, OnCommand, ONTAP, ONTAPI, RAID DP, RAID-TEC, SANtricity, SecureShare, Simplicity, Simulate ONTAP, SnapCenter, Snap Creator, SnapCopy, SnapDrive, SnapIntegrator, SnapLock, SnapManager, SnapMirror, SnapMover, SnapProtect, SnapRestore, Snapshot, SnapValidator, SnapVault, StorageGRID, Tech OnTap, Unbound Cloud, WAFL and other names are trademarks or registered trademarks of NetApp Inc., in the United States and/or other countries. All other brands or products are trademarks or registered trademarks of their respective holders and should be treated as such. A current list of NetApp trademarks is available on the web at http://www.netapp.com/us/legal/netapptmlist.aspx.